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The ENVI® Pocket Guide is a quick reference booklet not intended to be
read from cover to cover, although it can be. The intent is to provide users
with succinct steps on how to accomplish common tasks in ENVI.

If you need or desire comprehensive explanations of tasks in this guide,
refer to the following resources:

ENVI Documentation Center ENVI Help Articles
harrisgeospatial.com/docs harrisgeospatial.com/Support
ENVI Tutorials Tech Support
harrisgeospatial.com/docs/tutorials.html (+1)303-413-3920

ENVI Videos Email Support
harrisgeospatial.com/Learn/Videos.aspx support@nharrisgeospatial.com

Computer Based Training
harrisgeospatial.com/Learn/Training/cbt.aspx




GETTING STARTED

OPENING ENVI

1. Please reference ENVI Pocket Guide Volume 1 | BASICS if you need
instructions on how to open ENVI, load and remove data, or descriptions
of interface components and basic data preparation procedures.

ENVI Pocket Guide Volume 1 | BASICS
provides an introduction to familiarize users with common methods
for opening ENVI, loading data, navigating, and performing stretches.

You are currently referencing

ENVI Pocket Guide Volume 2 | INTERMEDIATE

which expounds a step further on intermediate procedures using ENV/,
IDL and ENVI LIDAR, assuming you have already mastered the basics.




GRID REFERENCE

1. Load any image (nadr, off-nadr, referenced or unreferenced) into ENVI,
then right click the image in the table of contents and select Zoom to

Layer Extent. [ Ca Tl ==z

File Options Help

- Featre 1 - m.®

2. Next click the center of
. ! Symbol V! Label ' Count 71 Gad a4 w4
the image and use the P T e =
mouse wheel to zoom
out until the image’s —

Map (xy)

edges are in view. s
MGRS

Feature Counting Tool fefa)=s

File Options Help

m oy Feawel v omv ™ @G 4 x4

[¥]Symbol  [7]Label [ Description [¥]Count [¥] Coordinates
Featwe | Giid | Count MGRS Desciption ]

If your image does not have a spatial reference you will not be able to
record coordinates, but you will be able to count features and record
File X,Y. Toggle check boxes next to Symbol, Label, Description,
Count or Coordinates to determine which attributes will be labeled.




3. Click the Feature Counting Tool icon @ to open the Feature Counting
Dialog Window. Right Click Description to turn on coordinates or

File (X,Y) for unreferenced images.

4. By default Grid is | ) Feoture Counting Properties
set to 4 x 4, but

: Feature Name Feature 1
yOU may adjust Feature Color (255.0.0)

H Descripion | mieseceleimi———
by entering new | irves 12 !
values. Turn | Smbo _[<"ASCI-ED) H

Feature Counting Tool o e ==
values on EileQptionsmHelp
andoffby | mmmee -mes

togghng ‘the [Symbol  [V]Label  [¥] Count VGid 4 x4

Count MGRS Description

check box.

1 10TET2605266683  boat 5 members

2 10TET2630866734  boat 7 man crew

1 UTETZ620266918 [boo Smnembers |
10TET2618966887 | boat fishing

10TET2757667254  boat INOP

10TET2824567600  boat docked

10TET2580366605  AAF Carrier

10TET2589166731 |
10TET2613566567 G,
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5.Click the Feature Counting Properties icon ™" to customize properties
such as feature name, font size, symbol, label position, label show and
count show.

6. Close Properties. [Er—— E=3 e o
Add other feature e
categories by pressing | @ems L
=, Add Feature icon. e =

By default new features
will be named ‘Feature
1". Highlight the text
then type to rename.

e+ =+ H XK




7. Select the feature you'd like to start counting by using the drop down
arrow and begin counting features by clicking your image.

8. As features are counted you may click the Description attribute and
type in associated information.

9. You may delete mistakes by highlighting row(s) and pressing 2K delete
icon to delete individually or ¥% icon to delete all.

10. To add a geographic grid click luamatatons¥| then click Add Grid Lines
from the dropdown menu. The new grid often defaults to WGS 1984
Web Mercator Projection.
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11. To customize the newly added grid go to the Layer Manager, right
click the Grid[...], then click Properties. Here you may change the
Coordinate System, Text and Line Color, XY Spacing and other items

12.

13.

in the following graphic:

Once satisfied with edits, from
the Feature Counting Tool
click File> Export> Shapefile or
Report (.txt).

Next go to the main ENVI
interface and click File> Chip
View To >PowerPoint or PDF
for a finished product.

@ Edit Properties

[Coordinate System

X Spacing

Y Spacing

Show Grid Lines
Show Intersections
Show Bounding Box
Show Text

Text Font Name

Text Font Size

Text Color

Text Orientation X-Axis
Text Orientation Y-Axis
Text Dffset
Geographic Format
Geographic Precision
Grid Color

Grid Thickness

Grid Linestyle

[E=8 Eol =
Grid
MWGS_1984_UTM_Zone_10N _d
1000
1000
True
True
True
Tiue
Helvetica
16
W00
Horizontal
Vertical
0
Degrees, Minutes, Seconds
4
[](255,255,255)
1

Intersection Symbol Size |5




Example NADR with Reference and Off NADR without Reference:

()
ES
(=)
Bl
m
il
m
el
m
]
ul

11



BAND MATH

1. Load a multi-spectral or hyper-spectral &) Band Math =
image into ENVI then select Band Previous Band Math Evpressons:
Algebra > Band Math from the Toolbox.

2. Once the Band Math dialog box

appears, enter any simple or complex
mathematical expression using b# N L
variables to represent the bands you [ —— ]

want to manipulate. Replace # with the

band number as seen in the example.

Band Math is a method used to create new raster data by performing
complex or simple mathematical functions on existing bands available in
one or more geographically referenced images. Analysts will be able to
compress data into isolated values of interest such as NDVI (Normalized
Vegetation Index) for example.




. Next click Add to List then OK
to open the Variables to Bands
Paring dialog.

. Initially the variables are unde-
fined. One by one, highlight each
Variable used in expression then
click the corresponding band in
the Available Bands List to define
the variables.

. Click Choose Output Filename
and name your new image or
elect to process in memory then
Click OK.

Variables to Bands Pairings

Exp: b4 +b3+b2

Variables used in expression:

B2 - [undefined
B3 i

B4 - [undefined] Variables to Bands Pairings. 7

Exp: b4 +b3+ b2

Variables used in expression:
B2 - ROI Resize (Blue:msi_reflectance.dat) (0.4826) Hawaii2.dat
B3 - ROI Resize (Green:msi_reflectance.dat) (0.5613)}Hawaii2.de

=-fig) Hawai
o RO

B4 - ROI Resize (Red.msi_reflectance.dat] (0.6546) Hawaii2.dat

o RO

o RO[| « m »
o RO

o RO| Available Bands List

o RO|| | = Hawai2 dat -

o RO| © ROl Resize (Coastal aerosolmsi_reflectance

&-@ Mq

o ROI Resize (Blue:msi_reflectance.dat) (0.48
o ROI Resize (Green:msi_reflectance.dat) (0.
o
O ROI Resize (Near Infrared (NIR)msi_reflect: _
o ROI Resize (SWIR 1:msi_reflectance.dat) (1~
o ROI Resize (SWIR 2:msi_reflectance.dat) [‘
- MapInfo -

< T | »

( Map Viariable to Input File )

Spatial Subset | Full Scene

Output Resultto @ File ) Memory

(o ) (e

Enter Output Filename [7] Compress

*s\Wrig3934\D ocuments\D ata\Hawaii_Landsat\ZETETICEAEE]

er)
=
&
=
T
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6. You may check your e e
results by linking - BEES e
two views; one view EAEIEEENT] ,
Geo: 19°38'40.52"N,155°47'39.46"w

T
=
=
(=)
<
o}

with a corresponding Map: 2069613354 21745558081 |7

spectral composite gg? Ui Zone 51, WES84 RS ——
that matches the [Eig;"%%gﬁ%sgsg%ﬁg — o @ELoe e
H ata: [0. .0 . 0. i R T A~
el S Dl
In your expression, MGRS: O5QKB06%6174555
and the Othel’ Proj: UTM, Zone 5N, WGS-84
. Hawai_432.dat
containing the output Fle. 4373.2112,6095.3064

. Data: [0.241691)
image, and then use =

the Cursor Value
icon to confirm
results. «
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Example Band Math on Landsat 7 Input b4 + b3 + b2 = Output:
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LAYER STACKING

1. Open each of the images you
wish to Layer Stack then click
Raster Management > Layer
Stacking in the Toolbox.

2. Set desired Output Map
Projection on the Layer Stacking
Parameters dialog, then Click
Import File

&) Loyer Stacking Parameters

Selected Files for Layer Stacking:

Output File Range:
@ Inclusive: range encompasses all the files
©) Exclusive: range encompasses fe overlap

Output Resultto @ File  ©) Memory

Enter Output Flename [ Choose |

Output Map Projecton  New...|
b
pl t/1

X Pitel Size Degiees

Y Pitel Size. Degrees

esrors [fossiNogbo

Layer Stacking is used to construct new multi-band imagery from

georeferenced images of many pixel sizes, extents, and projections.
Input bands are resampled and re-projected to a user defined pixel size
and spatial reference system. The resulting image will comprise the
extent of all images or only the region of overlap.



Stacking Input Fi =)

3. Using the shift key or ekl e Fi nfomatr =
. . E:n:;s :a: Ele CZ\BUss:rs;VS.ggS%S«CB\SDomm\DaIa\ILmdS o
i 13 -
CTRL, hlgh'lght each bandde EEeT[BueléﬂsrgsLytg] g
. . and3. il tandard
image you wish to band2dl Sensot Type: Londsa TH 2
. band1.dat g'yku[*,;lrm [|2nu| s =
ction : , th [ep]
stack, and then click e ez
Datum :'WGS-84
OK. Wavelengih : 222 to 2.22 Miciometers
Upper Left Comer: 3580,3985
Description: Fie Resize Aesul, x
;::;e l1ac(u: l.ﬂliﬁmﬂjy l?";zz
H r: 1.000000.[Mon Jun
4. Next click Reorder 1175 2016]

Files and then drag
and drop the bands in ok
the proper order from 1 bandl.dat Band 1]

least to greatest then 0K [Coms LX
Click OK_ :@.:::: OMMH |
] .&[Band“ I

G bandipat Band 1] |

|

|

der Files

.5; band4 Jat Band 1)
(E: band3Yat [Band 1) [Bmd”

[Bandll
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5. Choose output map projection from the list, set the X Pixel Size and Y
Pixel Size or accept defaults, and then choose the resampling method:
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e Nearest Neighbor: (BT Coyer Sadtmg Parameters . —
Uses the nearest pixel e ol L S P
without any interpolation | |tngd ki e T—

bandd dat [Band 1] T 3
e e
. band7.dat [Band 1 State Plane (NAD 3]

e Bilinear: Performs a Arening Zane?

. . . Argentina - Zone 3 e
linear interpolation — esE
using four pixels Outp Fl Rarge _

@ Inclusive: range encompasses all the files P

() Exclusive: range encompasses file overlap

e Cubic Convolution: Uses
16 pIXG|S tO appl’OXImate Output Resultto @ File ) Memory

X Pisel Size 0.00033375 Degrees

the sync function using Ertr 01t Flenone (e e i
CUbi C p Oly nomials ments\Data\1LandS at_Moabh\output i) Hesaﬂ\plingw
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6. Select Inclusive or Exclusive to stipulate the output file extent:
e Inclusive: geographic extent encompasses all the input file extents
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e Exclusive: contains only data extent where there is spatial overlap

7. Click Choose Output Filename and name your new image or elect to
process in memory then Click OK.

Example Layer Stack on Landsat 7 bands 1,2,3,4,5,7:

19



SWIR BANDS

Electromagnetic spectrum

=
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Red 632—-692nm
= | Red-edge 706 —746nm
NIRL 772 -890nm

NIR2 866 —954nm

Short-Wave Infrared (SWIR) Bands can be exploited to differentiate
between man-made materials that might otherwise be classified improperly
when using visible and/or other Multi-Spectral Imagery (MSI) Bands
because atmospheric aerosols have a lesser impact on SWIR bands. The
following sensors collect SWIR Information: Worldview 3, Landsat (4, 5,
7 and 8), SPOT (4 and 5), Terra & Aqua (MODIS/ ASTER), and VIIRS




1. Load an atmospherically corrected SWIR image into ENVI. ENVI
will automatically load it as a Grayscale image. If your image is not
atmospherically corrected yet, type “QUAC" in the Toolbox search
window to locate the Quick Atmospheric Correction tool, then run
the image through the QUAC wizard. Otherwise continue.

(7]
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2. Once the QUAC SWIR image is loaded take some time to get familiar
with the image using the navigation tools. Next you will explore each
SWIR band. Since the image is in grayscale bright spots reflect more
in each wavelength and dark pixels absorbs and reflect less, but gray
regions slightly absorb, scatter, and/or reflect.

3. Next right click the SWIR image in the table of contents and select
Band Animation. Expand the Band animation window if need be by
dragging from the corners.

21



SWIR BANDS

4. From left to right, the Play Buttons « « » will allow you to play backward,
or pause or play forward through each SWIR band to visualize which
bands show high reflectance for the feature(s) you are interested in.

Date and time
B Band Animati =
— == Frame number
[8/8) SWIR_QUAC. dat @~ .
QUAC (Resize (SWIRG-14NDV22183403.A245-054300739010_01_POD1 TIF)SWIR_Subset da) (2330 0000) Filename
[ ; + * ; t * |
W ] O Upegeam I3 Band
L U Annotate >
&= Link to >
: . Unlink from »
5. Click the tool icon @ ~ then > Annotate> ) o
Save Video Animation...

Frame number to dynamically display the H
SWIR band number while animation is

playing. Use the select icon to drag the
annotation to desired position.



6. Once you click Play forward or backward, you may adjust
playback speed using the delay dropdown menu.

7.Next right click the SWIR_<your image name>.series in
the table of contents and select Change Color Table >
Rainbow. This technique makes it easier to identify high
reflectance pixels per SWIR band. Once you've identified
high reflectance bands for the material you're interested in,
close the Band Animation dialog.

8.Next click the Data Manager [] and load a SWIR False Color Composite
using the bands you've previously identified. In this example I'm displaying
SWIR 7 as Red, SWIR 1 as Green and SWIR 5 as Blue. Click Load Data to
either the same view or a linked view.

23
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SWIR BANDS

24

9. If you have multispectral
imagery over the same
region, load your MSI in
a True Color Composite
into the same view or a
linked view.

10. Next highlight the MSI
True Color Composite
in the table of contents
and press Alt, Z
simultaneously on
your keyboard to open
a Spectral profile. Do
the same for the SWIR

False Color Composite.

(-] Spectral Profile (14NOV22183405-M2AS_R2C2-054300739020_01 POOLTIF) [ |- =[5

™ Impoit | Export~ {53 Options v
Spectral Profile

1200 |- 1 ]
'/' \ /
/ / 7/ \
., 1000 // / / 3
2wl [/ |\ Vv /ﬁ\ / \\ \ 4
2 / \ V / \
a8 \/ \ \
600 [- // A/ \\
//
00 [/ -
500 600 700 800 500
Wavelength (nm)
© | (] Spectral Profile {1] SWIR_QUAC.dat) ol e
™ Importv |l Export~ {53 Options v
Spectral Profile
6000 = N
£ o /| 1
S so000 — o E
s > E|
8 E >
3 E|
S 4000 - E
3000 -
- e e
1400 1600 1800 2000 200
Wavelength (nm)
) [ Wavelengh | v.[DataValue F e




11. Position the two
spectral profiles side
by side then select
and compare spectra
via left click with the
select tool Ik while
simultaneously
pressing the Shift key. J§
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12. In the above example the image to the left is an MSI True Color Composite
and the Image to the right is a SWIR 751 False Color Composite. Notice
how the roof in the cross hair appears to be the same material as the
left adjacent roof until analyzing in the SWIR image which visually and
spectrally draws out the difference in material.

25



13. If you wish to classify your SWIR Image at this point, type Spectral
Angle Mapper Classification in the Toolbox search window and double
click the Spectral Angle Mapper Classification Tool. For a comprehen-
sive tutorial and explanation of this tool, visit the ENVI online
Documentation Center at:

1%}
=
=
)
e
=
7

www.harrisgeospatial.com/docs/spectralanglemapper.html

Visit http://speclab.cr.usgs.gov/ for a comprehensive list of materials in
association with best SWIR bands used to identify specific materials.
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SPECTRAL ANALYSIS

Spectral Profile Interface
Some numbers represent GUI groups separated by commas from left to right.

1. Spectral Profile with X & Y axis 8. Choose X axis

2. Remove selected curve, Remove 9. (X) Electromagnetic Spectrum/
all curves, Edit data value Wavelengths in nanometers

3. Show/Hide Properties 10. (Y) Data Value

4. List of collected spectra/ classes 11. Import ASCII or Spectral library,

. . Export ASCII, Spectral Library,
5. Show/High extra info, General PDF, Image or PPT, Profile

Properties, Curve/ Spectra Window Options

properties

12. 1 x sample spectra plot (select
multiple by clicking image

7. Choose Y axis while holding Shift)

6. Stack plots, Reset plot range



Elmv ke Export & npﬁms{

Data Value

~ Spectrdl Profile

e
General| Curve | f—
|
Name Foﬂf type 1
Color W55.00)
Line Style
hickness 1
500 600 700 800 900 lm No symbol
Wavelength (nm) SymbolCoor | I000)

%[ Wavelength v k[ DalaValue

29



PE———
2 Scatter Plot Tool: [1] SWIR_QUAC.dat [fola==

and then highlight it in the
table of contents then go
to the main menu and click
Display > 2D Scatter Plot.

2| 1. Load your SWIR 751 band Ele Options _Help

e combination False Color N % % FodTwe2 ~imy [ @ Orusa
2 Composite image into ENVI _ SWIR_QUACdat

= 7

g

6000

QUAC (Resize...1210.0000)
40]00

20‘00

= 2000 4000 6000 8000 100001200014000
QUAC (Resize...2260.0000)

—7

Short-Wave Infrared (SWIR) Bands will be used again in this section to
further investigate the differences in material using 2D Scatter Plot and
the Spectral Profile in tandem. These methods can be applied on any
image containing more than 1 band.

30



2. Take a moment to hover your mouse over each icon on the Scatter
Plot dialog to read the Tooltips. Then toggle the Density Slice icon [@) to
color your plot. You can change the color scheme by clicking Options
> Change Density Slice Lookup. Leave Full Band unchecked so you can
zoom into your scatter plot and imagery in tandem using the mouse
wheel or check it to maintain the full extent of the plot when zooming
in and out of the imagery.
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3. Next highlight the default Class 1 and rename it to whatever material
you wish to compare then click the ™4 Add Class icon to add more
spectra classes for comparison. Name classes accordingly. In this exam-
ple we will compare Roof Type 1 & 2.

4. Change Scatter plot bands by clicking File > Select New Band X or
Y-Axis. The example plot shows SWIR 1 on X and SWIR 5 on Y.
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5. Right click in the Scatter
Plot dialog and select
the patch size you
desire. Click the Class
dropdown window and
ensure you are working
with the first class.
Then, within the Scatter
Plot window hold CTRL
and left click and move
around the plot. Notice
the corresponding pixels
dynamically highlight
within the image as you
move your mouse.

[%2)
n
Z
=
=
<
—
<
o
=
(&}
w
a
n

32



6. Hold left click within the scatter plot and draw a polygon around the
same pixels to select them. Next right click and select clear class.

7. Now within your ENVI View first ensure the [ .2D Scatter Plot icon is
active. Then right click the image and select Cursor Mode > Region of
interest. Feel free to play around with the other cursor modes by holding
left click as you drag the mouse around the image while observing the
scatter plot.
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8. While in Region of Interest (ROI) cursor mode draw a polygon around
your first spectra sample by either left clicking individual vertices or
holding left click to freehand draw. Double click to finish.
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9. Within the Scatter Plot window use the
drop down to select the next class then
repeat step 8 to collect a sample.

10. Next right click within
the Scatter Plot window
and select Mean all. This
gives you the statistical
mean for all spectra
captured within the
class ROI's.

: F
2 Scatter Plot Tool: [1] SWIR_QUAC.dat
File Options Help

CWC B B Foof Tuoe 1 I EARCRY @  [CFulBand
FRoof Type 1
Roof Type 2 SWIR_QUAC.dat )

1 L
T

QUAC (Resize...2165.0000)
2000 4000 6000 8000 10000 12000

L

L 2000 4000 6000
5 QUAC (Resize...1210.0000)

[—2




11.

Next hold shift key and
right click several disparate
pixels within the Scatter
Plot to show a graphical
comparison of mean
deviation among the spectra
in question. This indicates
the degree of correlation
between the X and Y
bands of choice.

| (L] Scatter Plot Spectra: SWIR_QUAC.dat

,_: Import v H Exportv {2 Options v
Spectral Profile

Data Value

6000

5000

4000

3000

2000

1400 1600 1800 2000
Wavelength (nm)

2200

:(Wavelengh  +] v.[DataValue

OF &

(%]
o
m
]
=
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>
=
>
=
>
>
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(%]
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12. Lastly right click Classes
within the ENVI table of
contents and select Statistics
for All Classes then select
the SWIR image in the File

selection window and hit OK.

[ Classification Statistics View: SWIR_QUAC.dat
Eile Help
= seectPote

[EY T,

Class Means: SWIR_QUAC.dat

5000 |-

4000 £

Data Value

3000 &

2000 =

1600 1800 2000 2200
Wavelength (nm)

® x(Wavskogh ] v[Daavae 7] J &
5 Locatestaty @ [T [ Report Precision >
Closs Summay PhelCont  Percent
Beckgound 323 L
@ on
s o0m
Backgound
Basc Stats Min Max Meen Sdbev
Band1 0 10083 25421 104754
Band2 0 788 192058 106473
Band3 0 12858 26027 12808
Bandd, [ 13739 205965 %20
Band5 0 12987 182933 £
Band6 0 12131 165441 =264
Band? o 18161 87227 00581

You may save your findings to a Spectral Library for future comparisons.
Standard Deviation is the average distance to mean for the spectral
material in question. Export the following report by clicking

File > Export to Text File.




IMAGE CALIBRATE

1. Open your metadata file, for example [« =%
*xx %% MTL.txt in ENVI. This file e
populates the associated imagery Soil
in your Data Manager.

g 3

Reflectance (%)

8

2. Next right click the multi-band
image in the Data Manager and
load a True Color composite.

s

Water

°

°

1 2 3 4 5 6
Wavelength (micrometers)

Spectral reflectance curves are used to distinguish materials that make
up the Earth’s surface. Spectral libraries are primarily created in the field
using a spectrometer instrument. Satellite imagery requires calibration
before comparing against spectral libraries collected in the field because
satellites measure radiance which is often tainted by occurrences and
nuances such as aerosols, shadows, clouds, the Sun’s position, and more
thus resulting in distortion.

37



3. Type QUAC in the Toolbox search window and then double click
Quick Atmospheric Correction (QUAC) to launch the QUAC wizard.

& File Selection (=3
Select Input Data Subsetby [ @) [ & fy 6% ‘W‘
LC80410302013213LGNDO_MTL_MuliSpectal]

[ LC80410302013213LGNO0_MTL_Panchromati

[ LCO0410302013213LGNO0_MTL Cirus
LC80410302013213L GNOO_MTL_Thermal

B LCO0410302013213LGNO0_MTL_Quaity

« = v
»  File Information

[ Spaial Subset.. | (36225114)(4168:5405) {

[ Spectial Subset.. | 7of 7 Bands

l Mask.. | No mask

Columns: fiom 3622 1o 5114  total 1493  pixels

[ JERCi 0K [ Cancel Rows: fom 4168 1o 5405  total 1238 piveks




4. Highlight the Multispectral image in the Select Input Data then click Spatial
Subset. Draw a box around the region you will analyze, avoiding heavily
clouded areas and areas with large bodies of water, then click OK.

5. In the next dialog the default
Sensor Type is derived from
metadata. Name your output Input Raster  [Subset] LCB0410302013213LGNOO_b
file and ensure its being saved
in a desired location. Toggle
Preview and click OK if satis- Output Raster ~ snis\Data\1Landsat_QUACNQUAC dat .|
fied with preview.

Sensor Type [Lmdsat TM/ETM/0LI v ]

© [V Preview [7] Display result

6. Link your views and inspect
results by analyzing each
Spectral Profile.
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=
[l
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LANDSAT Before & After Atmospheric Correction:

w
<
o
)
<<
o
w
[ds)
<C
B

L] Spectral Profile (LC ) MTL Mult o -@- a5 | L Spectral Profile (QUAC.dsy) fol o=
% Impott v | Expoty () Options v " Impot v fd Expot > () Opiions »
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LIDAR FEATURE EXTRACTION

ENVI LiDAR Interface

Some numbers represent GUI groups separated by commas from left to right.

1. New Project, open Project or LAS, Process Data, QA Mode, QA Mode
with Center Line, 3D Viewer, Select Cross Section, Cross Section Top
View, Reset Perspective View, Reset Isometric View, Measurement Tool,
Height Palette Editor, Color by Height, Color by Classification, Shade
by Intensity, Color by RGB, Color by Viewshed Analysis, Filter Points by
Height, Launch Products in ENVI, Launch Products in ArcMap,
Screenshot to PowerPoint

2. Main Viewer Window 4. Navigation Tools, Navigation Window

3. Session Operations Log 5. Layer Manager

For a more comprehensive understanding of ENVI LIDAR visit the online
Documentation Center, Videos and Tutorials.
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1.0pen ENVI LiDAR by clicking Start > All Programs > ENVI 5.x > ENVI for
ArcGIS® > ENVI LIDAR 5.x (32-bit).
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Please select LAS or other data files to be imported into project;
C:\Users\Wrig999#\Documents\Data\01bLIDARextract\Geiger_LAS Con

fidential\PocketGuide02\PocketGuidel2.ini.

2. Next click File > New Project and then navigate to the directory you
wish to save your project and name it yourProjectName.ini. The .ini is
the file extension used to save LIDAR Project sessions. You may open
existing projects by locating .ini files via File > Open.

3. Click OK when prompted to select the LAS or other data to be imported
for your project. Navigate to the location of your LAS file and open it. You
will then be prompted Yes or No for additional data. Click No if satisfied.
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=
o
File Content >
Qo
X (East) ¥ (North) 2 (Height) E E
281768.930 6263521790 70,760 E| =
281769.110 6263521,570 70.270 ?
281768.840 6263522,010 69,110 Ul
281769.550 6263521.140 67.170 i
281767.700 6263523.490 70260 =
281767.420 6263523.690  70.070 &
281767.220 6263524.180  69.670 =]
281760.160 6263532.770  88.020 =
281767.490 6263523.970  67.000 -
Coordinate System
Input Projection System: (UTM -]
Input Datum: [wssm v]
Input Units: Meters %

UTM Zone: ;20 ] caulated LONLAT: -114.54267 56.46554

[ viewtesder ][ Advanced |

o Lok J[ cone ]

4. If the proper coordinate system is attributed in your LAS metadata
you will be prompted to confirm its usage. Otherwise you will need to
designate a Coordinate System in the Convert Format dialog. Choose
the input data’s projection and the click OK.
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5. You may now change the point
cloud symbology by clicking the
Height Palette Editor:

4
b PAPZIHA

or Color by Height, Color by
Classification, Shade by Intensi-
ty, and Color by RGB if the LAS
contains the necessary metada-
ta. In the Height Palette Editor
click Load palette and select
Earthtones.

| e ey e
Height Range
© View Extents  Minimum: 0.00 D =
© Full Extents  Min, Project Height: 21.59
Maximum: 1,00 D
Max. Project Height: 220.31
Clip View Extents (top 1%, bottom 1%)
Color Space
[¥] smooth Color Transition
e r—
Save This Palette as... )
Iwm ]
[} Cox )




6. Next, in the Navigation a A -« »
Window, left click and drag < ) dump(my 10
a rectangle around the X v
region you are interested View Point Density (ptsfm~2): S0
in extracting or the entire
frame.
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7. Next click the Process Data
icon @ which brings up
the Project Properties
dialog window.

®: 513165.004 Y: 3896723.763 Z: 193.41 Size: 180m % 195m
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8. If you decide to toggle Produce Point
Cloud keep in mind that ENVI LIDAR
will generate a new classified Point
Cloud which coincides with the
American Society for Photogrammetry
and Remote Sensing (ASPRS) LAS
Specification 1.x.

9. In this exercise we are interested in
extracting buildings and trees. In the
Project Properties dialog toggle Produce
Buildings and Produce Trees. Adjust
File Size Limit if necessary or accept the
default 500Mb. Note the output data
will be saved to the Products Folder
which was automatically generated
within the directory which contains
your ProjectName.ini.

Computed
Classification  Description
Value*
Not Processed

1 Unclassified
2 Terrain
3 Near terrain
5 Trees
6 Buildings
14 Power line
15 Power pole




H i =
10. Next click Start Processing. 5
el
n
M m
=
Outputs | Area Definion | Production Parameters =
m
Products File Names and Formats. Q
[ Produce Orthophot Orthophoto File Neme: btmap (GeoTIFF format (*.tF) - B
[IProduce DSM DSM File Name: dsm ENVI elevation format (*.dat, *.hdr) v
[ Iproduce DEM DEM Fie Name: dem ENVI elevation format (*.dat, * hdr) -
([]Produce Buidngs Vector Fie Name: budings 5t format (*.shp) B
odicn Treee Trees Fie Name: trees (5t Format. (*.sho) B
[Iproduce Power Lines Power Lines File Name: powerlines SHP format (*.shp) Y
] Produce Point Cloud Point Cloud Fie Name: pointCloud LAS format (* Jos) v
[ Produce DEM Contours. DEM Contours File Name: demContourLines SHP format (*.shp) -
[ Produce Terrain TIN Terrain TIN File Name: terrainTIN SHP format (*.shp) v
[TIProduce 3D Viewer Database
Point Cloud Export Export Coordinate System
File Size Limi (KBytes): 500000 Profection System: [um -]
Dotum: Wes04 =
7] Binary Fles Separated by Classification ( )
unks: Meters -
2o
Products Folder Parameters Templates
Products Folder: Products [ Save This Project a5... ]
Full Path C er_LAS (i v

o (i J [ saveandciose | [ saveandprevew | [ stert Processing Concel
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11. ENVI LIDAR will default to QA
Mode once processing is complete.
While in QA Mode, double click
any of the Vector Layers within the
Main Viewer Window and select New Text Annotation...
from the following options to make
any necessary corrections:

New Correction...
Edit Building Contour...
Delete Building Contour
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New Observer Point...

Copy Pick Results to Clipboard

12. Once satisfied with edits you may toggle the 3D Viewer & icon for
a 3D Model of your data or you may Launch Products in ENVI, or
Launch Products in ArcMap for further analysis or Screenshot to
PowerPoint using these icons: [ [ L3
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Sample 3D View from Point Cloud:
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BATCH PROCESSING

IDL (Interactive Data Language) is the programming language that
drives ENVI. Users can use IDL alone or in tandem with ENVI by use
of the ENVI API. The ENVI APl uses an object oriented methodology
to manage and manipulate data, views and the overall state of the
application. Many workflows require routine steps the user must
perform whenever he or she wants a particular product or result.
Such workflows can be automated using IDL ENVITasks, thus improving
efficiency while mitigating user error. This approach is commonly
referred to as Batch Processing which generally means to collect a
set of instructions or jobs and then execute the set without user
interference. The next example demonstrates how to Batch subset
and reproject every image in a specified directory.
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IDL Workbench Interface

Some numbers represent GUI groups separated by commas from left to right.

o
19]
wn
&
o
o
[a
o
ju g
S
<<
[an}

1. Main Menu/Toolbar: New Program, New Project, Open, Save, Cut,
Copy, Paste, Undo, Redo, Back, Forward, Compile, Run, Stop, Step In,
Step Over, Step Out, Call Stack, Reset

2. Program Editor Window 4. Tabs: Project, Outline,

3. IDL Console/ Sandbox Variables | List of Project Variables

Explore Getting Started with IDL Programming manual or ENVI Online
Help for a more comprehensive explanation of the IDL Workbench.
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. Open IDL by clicking Start > All Programs > IDL 8.x > IDL 8.x.
. Next click the No icon to create a new empty program script.

. Click the File > Save As then navigate to your desired directory and
name the program batchReprojectDirectory.pro and click Save.

A general understanding of object oriented programming and coding i
conventions are useful when working with IDL. The following resources
will be of use in building your understanding:

Object Oriented Programming:
WwwWw.geo.mtu.edu/geoschem/docs/IDL_Manuals/OBJECT%20PROGRAMMING. pdf

Coding Conventions:
www.harrisgeospatial.com/docs/case versus switch.html
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4. Right click in the Program Editor
Window, click Preferences then
check Show line numbers. This will
help identify errors if debugging is
necessary. Click OK.

5. In the Program Editor Window,
enter the following lines of code:

pro batchReprojectDirectory
compile_opt idl2, hidden

NV A wN e

end|

6. The code in blue must match the
filename. All IDL programs start
and end in this way.

B4 Preferences (Filtered)
type fitertent
Genenal

Appearance
Editors
Text Editors

o o)==
Text Editors v

See [Colors and Fonts] to configure the font.

Undo history size: 200
Displayed tab width: 4
[llnsert spaces for tabs

[V]Highlight current line.

] Show print margin

(] Show line numbers

) Show range indicator

] Showwhitespace characters

7] Show affordance in hover on how to make it sicky
When mouse moyed into hover:
[¥] Enable drag and drop of text

[91Wam before editing a derived file

9] Smart caret positioning at ine start and end

Appearance color options:

Color: ]

Find scope
Selection foreground color
Selection background color
Background color
Foreground color
Hyperlink

“Colors and Fonts'




i . T batchReprojectDirector) £
7. Next we will use ; I [
. H . 3 T
WhICh |nd|CaT_eS 4 ; Start the application %
- S
non eXECUtable 6 ; Set directory Path a
. > 2
comments, to write 4 I—— =
9
the Steps we Want to 10 ; list of images in path
11
perform In pseUdO 12 ; Loop through and Reproject each image in directory Path
code. This ensures 1 . .
. 14 ; Process a spatial subset: Upper Left (X,Y), Lower Right (X,Y)
good logic and code |
T 16 ; Get the task from the catalog of ENVITasks
readability for other 17 ) o
18 ; save result to TIFF appended with new projection
users. To subset and s I
el

reproject the contents
of a desired directory
the following steps
must occur

It is important to note the \O1Batch directory and output \Reprojected
directory were already created. To prevent path typo’s drag the folder

into the IDL Console/ Sandbox then copy and paste the resulting string
into your code.




8. We can now begin writing actual code to accomplish each
commented step.

; Start the application
e = EWI()

9. The first four .
comments are as 6 .
. . 7 ; Set directory Path
Slmple as dedaﬂng 8 Path = "C:\Users\Wrig9994\Documents\Data\@1Batch"
9
10
11
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variables which start
the application, sets |

; Set output Path
OutDIR = Path + "\Reprojected\’

. . 13 ; list of images in path
the input directory, 14 filelist = file search(Path, **.tif')
15
SetS the Output 16 ; Loop through and Reproject each image in directory Path

dlreCtOFy and CreateS 18 ; Process a spatial subset: Upper Left (X,Y), Lower Right (X,Y)
a fl'e ||St array ObJeCt 20 ; Get the task from the catalog of ENVITasks
by searching the

2 ; save result to TIFF appended with new projection

input directory for
wildcard/all files
indicated by *
meaning all files
ending in .tif.
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10. We will now use a “for loop” to iterate, though our list of files stored in
the fileList object and subset & reproject at each iteration.
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16 ; Loop through and Reproject each image in directory Path

17 for i=0, n_elements(filelList)-1 do begin

18

19 File = fileList[i]

20

21 ; Process a spatial subset: Upper Left (X,Y), Lower Right (X,Y)
22

23 ; Get the task from the catalog of ENVITasks

24

25 ; save result to TIFF appended with new projectionl

11. At this point we are now ready to take advantage of
ENVITask snippets. Open Google Chrome and navigate to:
http://www.harrisgeospatial.com/docs/envitask.html. Scroll below
TaskName until you find a task applicable to the problem we need to
solve. Click ReprojectRaster and notice there is a snippet which already
accomplishes 90% of what we need to do. Highlight and copy the
ENVITask snippet from Raster = e.OpenRaster(File) to the last line.
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12. Go back to IDL Program
Editor Window and
highlight our last 3
comments and then
paste the ENVITask
snippet. Afterwards
highlight any of the
newly pasted code not
indented properly and
hit the tab key until
properly indented under
the for loop then type
endfor as shown.

16 ; Loop through and Reproject each image in directory Path
17 for i=0, n_elements(fileList)-1 do begin

18

19 File = fileList[i]

20

21 Raster = e.OpenRaster(File)

22

23 ; Process a spatial subset

24 Subset = ENvISubsetRaster(Raster, Sub_Rect=[600,200,799,399])
25

26 ; Get the task from the catalog of ENVITasks

27 Task = EMVITask('ReprojectRaster")

28

29 ; Get the

30 ; NAD_1983_StatePlane_Colorado _North_FIPS_0501 Feet
31 ; coordinate system

32 CoordSys = ENVICoordSys(COORD_SYS_CODE=2231)

33

34 ; Define inputs

35 Task.GDORD_SYS = CoordSys

36 Task. INPUT_RASTER = Subset

37

38 ; Define outputs

39 Task.OQUTPUT_RASTER_URI = e.GetTemporaryFilename()
49

41 ; Run the task

42 Task. Execute

43

a4 ; Get the data collection

45 DataColl = e.fata

a6

47 ; Add the output to the data collection

48 DataColl.Add, Task.Output_Raster

49

50 ; Display the result

51 view = e.GetView()

52 Layer = View,Createlayer(Task,Output_Raster)

S3 endfor




13. Next modify the ENVITask snippet by changing parameters such as
Sub_Rect and COORD_SYS_CODE to coincide with your data. The
subset rectangle’s upper left and lower right can be obtained using
the Cursor Value in ENVI. To obtain your desired COORD_SYS_CODE
navigate to C:\Program Files\Exelis\IDL85\resource\pedata\predefined
and search either of the two text files in WordPad using CTRL + F.
Do not Modify these files.
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14. Lastly add the following lines of code to write the new output rasters
then hit the compile @ button and check the IDL Console/ Sandbox

for any errors. Red in the Console indicates errors and green indicates
a successful compile:

41 ; save result to TIFF appended with new projection

42 append = "_subset_WGS84_UTM_11N.tif"

43 out_filename = OutDIR + FILE_BASEMAME(Raster.nane, ".tif') + append
44 Task.OUTPUT_RASTER.export, out_filename, "tiff"

15. If your program has errors use the line number in the error message to
address the issue. Otherwise click run ® to execute the program.
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Complete Batch Subset & Reproject Directory Example:

; Description:
s - Searches a directory and reprojects every image
3 - then appends new projection to end of filename
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pro batchReprojectDirectory
compile opt idl2, hidden

; Start the application
e = ENVI()

; Set directory Path
Path = 'C:\Users\Wrig9994\Documents\Data\@1lBatch’

; Set output Path
OutDIR = Path + "\Reprojected\’

; list of images in path

fileList = file_search(Path, '*.tif")

; Loop through and Reproject each image in directory Path
for i=0, n_elements(filelList)-1 do begin
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File = fileList[i]
Raster = e.OpenRaster(File)

; Process a spatial subset: Upper Left (X,Y), Lower Right (X,Y)
Subset = ENVISubsetRaster (Raster, Sub_Rect=[ 2428,4002,4018,526

; Get the task from the catalog of ENVITasks
Task = ENVITask('ReprojectRaster')

; Get the

; "WGS_1984 UTM_Zone_11N"

; coordinate system

CoordSys = ENVICoordSys(COORD_SYS_CODE = 32611)

; Define inputs
Task.COORD_SYS = CoordSys
Task.INPUT_RASTER = Subset

; Run the task
Task.Execute
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; save result to TIFF appended with new projection
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append = " _subset WGS84 UTM 11N.tif"
out_filename = OutDIR + FILE_BASENAME(Raster.name, '.tif') +
append

Task.OUTPUT_RASTER.export, out_filename, 'tiff’

; Get the data collection
DataColl = e.Data

; Add the output to the data collection
DataColl.Add, Task.Output_Raster

; Display the result

newRaster = e.OpenRaster(out_filename)
View = e.GetView()

Layer = View.CreatelLayer(newRaster)
endfor

end
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